Sign in to follow this  
Cyan

Map testen problem

Recommended Posts

Hey, habe noch ein problem.. x) Wenn ich andere maps ausprobiere mit urban terror klappt es ( /map "Mapname") Aber wenn ich dann das mit meiner map mache klappt es nicht die console sagt mir map couldnt be found in map /maps bsp. oder so ähnlich. Obwohl ich eine bsp datei in meiner pk3 datei hab.. Meine fertige pk3 liegt im q3ut4 ordner.. was mach ich falsch? :(

Share this post


Link to post
Testest du die Maps auf deinem lokalen server? (Urban terror -> Start Server -> Bla) Oder auf einem 'richtigen' Server? (Sorry, mir fehlen die Fachbegriffe...) Falls letzteres der Fall sein sollte, musst du die Map erst auf den Server laden.

Share this post


Link to post
[quote=Cyan] die console sagt mir map couldnt be found in map /maps bsp. oder so ähnlich. [/quote] Naja, es wär schon besser die genaue error message zu posten. Wenn's "Can't find map maps/mapname.bsp" ist dann liegts wohl daran, dass es einfach kein mapname.bsp im "maps" ordner von deinem Urt ordner bzw. in den "maps" ordnern in deinen pk3s gibt. Nur um sicher zu gehen, du musst mit dem /map befehl den bsp namen angeben, nicht den vom pk3. Hoffentlich nennst du des pk3 file aber genau so wie des bsp file.

Share this post


Link to post
bei mir gab es auch mal eine fehlermeldung, bzw die map hat dann nicht geladen. das lag daran das ich bei "start server" ein serverpasswort eingetragen hatte. weiß nicht ob das in deinem fall auch was mit den einstellungen bei "start server" zu tun hat :x

Share this post


Link to post
Es kann sein, dass du einen Ordner erstellt hast in dem die Unterordner maps, models, textures etc sind und den gezippt und zur pk3 gemacht hast. Das wäre allerdings falsch, da du beim verpacken nur die "Unterordner" markierst und zusammen verzippst, ohne nur einen Ordner mit allen Unterordnern zu verzippen, und danach in mapname.pk3 umbenennst.

Share this post


Link to post
Skapunk: Nein nicht auf einem richtigen. Happyday: Ja genau er sagt "Can't find map maps/mapname.bsp" Doch ich habe meine bsp datei im maps ordner von der pk3. Habe ich auch gemacht, zumahl die pk3 und die bsp file gleich heißen. Benoit: ich starte es ja nicht von "Start server" . Ich will es vom menü aus starten mit der console. Ausserdem wird die map auch gar nicht bei der "Start Server"-liste angezeigt (Ja ich habe es mit verschiedenen Modis (TDM,TS..) versucht. Schnork: Nein , das hab ich auch so gemacht wie du gesagt hast.. Sollte ich lieber winzip anstatt winrar nehmen? Also hier meine ordner: Levelshots - levelshot.jpg Maps - mapname.bsp (Ich habe eine BSP meta mit dem gtkradianten 1.5 gebaut) scripts - mapname.arena (Ich habe es auch einmal ohne ausprobiert, kein erfolg) Textures/mapname - texture1jpg,texture2jpg etc

Share this post


Link to post
Ausserdem wird die map auch gar nicht bei der "Start Server"-liste angezeigt (Ja ich habe es mit verschiedenen Modis (TDM,TS..) versucht. Das ist normal. Du solltest die Map dennoch auf deinem lokalen Server mit /map ut4_Fickdiekatze starten können

Share this post


Link to post
[quote=SkaPunk]Das ist normal.[/quote] Das ist nicht ganz so normal weil er anscheinend ein mapname.arena im pk3 hat. Also für mich klingt das alles so als wär dein pk3 nicht ganz richtig, oder einfach nicht am richtigen ort. Nur nochmal um sicher zu gehen, dein pk3 muss ein .zip file sein, nicht .rar. Wenn alles nichts hilft, kannst ja auch mal des pk3 hochladen, damit man sich des mal anschauen kann.

Share this post


Link to post
Achsoo zip file ich hab es als rar datei verpackt xD Oh gott! Danke! Ich werde mir jetzt erstmal winzip runterladen und es ausprobieren. Nebenbei: Hast du das HappyJumpTutorial gemacht? :D Also : Es lag wirklich daran, und es hat auch gleich geklappt, jedoch wird mein levelshot nicht angezeigt und die texturen werden auch nicht angezeigt, obwohl ich alle ornder (Maps, textures,etc) als zip verpackt habe..

Share this post


Link to post
Der Levelshot muss genau so heißen wie dein bsp file, sonst wird nichts angezeigt. Ich geh mal davon aus, dass du mit "texturen werden auch nicht angezeigt" meist, dass alle Texturen die blau-weiß-rote "missing textures" Textur zeigen. Des heißt so viel wie, da wo in der bsp angegeben ist, wo die Texturen sein sollten, sind sie nicht. Könnte daran liegen, dass ein Ordner falsch heißt, z.B "texture" statt "textures" oder ein Ordner zu viel / zu wenig da ist, in dem die Texturen liegen. Es ist schwer zu sagen worans genau liegt, wenn man des pk3 nicht vor sich hat. [quote=Cyan]Nebenbei: Hast du das HappyJumpTutorial gemacht? :D [/quote] yup

Share this post


Link to post
Du bist ein Gott :D Komisch das mit den levelshots wurde in keinem tutorial erwähnt.. Das Problem mit den Texturen war so wie du gesagt hast: Mein ordner im textur ordner hatte einen anderen namen als der in meinem urt-mapping ordner. Vielen dank du hast mir sehr geholfen, Und danke auch an alle anderen! Die Map ist für ein SR8 only server für mein clan :D Sehr gute map HappyDay (: Danke nochmal xD

Share this post


Link to post
Dieser Thread ist ziehmlich alt. Bitte überlege ob du nicht lieber einen neuen Thread startest anstatt diesen wiederzubeleben.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Who's Online   0 Members, 0 Anonymous, 1 Guest (See full list)

    There are no registered users currently online

  • Forum Statistics

    1,598
    Total Topics
    21,398
    Total Posts